summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2018-02-01 17:14:42 +0100
committerDavid Sterba <dsterba@suse.com>2018-02-02 16:01:59 +0100
commit6d3fea8f46568ae9f54bd50f9de2aeeb76e0cd23 (patch)
tree0e6fa544f1b717e1132cb752902a05912ff5ced5
parent3876f9f1d5aee34f9c625be0226fcca22fd598d9 (diff)
btrfs-progs: check: rename files after moving code
Add prefixes to the files so it's clear they belong to the mode group. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile2
-rw-r--r--check/main.c6
-rw-r--r--check/mode-common.c (renamed from check/common.c)2
-rw-r--r--check/mode-common.h (renamed from check/common.h)4
-rw-r--r--check/mode-lowmem.c (renamed from check/lowmem.c)4
-rw-r--r--check/mode-lowmem.h (renamed from check/lowmem.h)6
-rw-r--r--check/mode-original.h (renamed from check/original.h)5
7 files changed, 15 insertions, 14 deletions
diff --git a/Makefile b/Makefile
index d30f1d29..327cdfa0 100644
--- a/Makefile
+++ b/Makefile
@@ -113,7 +113,7 @@ cmds_objects = cmds-subvolume.o cmds-filesystem.o cmds-device.o cmds-scrub.o \
cmds-restore.o cmds-rescue.o chunk-recover.o super-recover.o \
cmds-property.o cmds-fi-usage.o cmds-inspect-dump-tree.o \
cmds-inspect-dump-super.o cmds-inspect-tree-stats.o cmds-fi-du.o \
- mkfs/common.o check/common.o check/lowmem.o
+ mkfs/common.o check/mode-common.o check/mode-lowmem.o
libbtrfs_objects = send-stream.o send-utils.o kernel-lib/rbtree.o btrfs-list.o \
kernel-lib/crc32c.o messages.o \
uuid-tree.o utils-lib.o rbtree-utils.o
diff --git a/check/main.c b/check/main.c
index b4ecd5e9..c051a862 100644
--- a/check/main.c
+++ b/check/main.c
@@ -43,9 +43,9 @@
#include "kernel-shared/ulist.h"
#include "hash.h"
#include "help.h"
-#include "check/original.h"
-#include "check/lowmem.h"
-#include "check/common.h"
+#include "check/mode-common.h"
+#include "check/mode-original.h"
+#include "check/mode-lowmem.h"
enum task_position {
TASK_EXTENTS,
diff --git a/check/common.c b/check/mode-common.c
index d6abf6d6..1b56a968 100644
--- a/check/common.c
+++ b/check/mode-common.c
@@ -21,7 +21,7 @@
#include "transaction.h"
#include "utils.h"
#include "disk-io.h"
-#include "check/common.h"
+#include "check/mode-common.h"
/*
* Search in csum tree to find how many bytes of range [@start, @start + @len)
diff --git a/check/common.h b/check/mode-common.h
index 09745af4..ffae782b 100644
--- a/check/common.h
+++ b/check/mode-common.h
@@ -18,8 +18,8 @@
* Defines and function declarations for code shared by both lowmem and
* original mode
*/
-#ifndef __BTRFS_CHECK_COMMON_H__
-#define __BTRFS_CHECK_COMMON_H__
+#ifndef __BTRFS_CHECK_MODE_COMMON_H__
+#define __BTRFS_CHECK_MODE_COMMON_H__
#include <sys/stat.h>
#include "ctree.h"
diff --git a/check/lowmem.c b/check/mode-lowmem.c
index d2099fcb..62bcf3d2 100644
--- a/check/lowmem.c
+++ b/check/mode-lowmem.c
@@ -25,8 +25,8 @@
#include "internal.h"
#include "utils.h"
#include "volumes.h"
-#include "check/common.h"
-#include "check/lowmem.h"
+#include "check/mode-common.h"
+#include "check/mode-lowmem.h"
static int calc_extent_flag(struct btrfs_root *root, struct extent_buffer *eb,
u64 *flags_ret)
diff --git a/check/lowmem.h b/check/mode-lowmem.h
index 39deff0c..73d57999 100644
--- a/check/lowmem.h
+++ b/check/mode-lowmem.h
@@ -17,10 +17,10 @@
/*
* Defines and function declarations for lowmem mode check.
*/
-#ifndef __BTRFS_CHECK_LOWMEM_H__
-#define __BTRFS_CHECK_LOWMEM_H__
+#ifndef __BTRFS_CHECK_MODE_LOWMEM_H__
+#define __BTRFS_CHECK_MODE_LOWMEM_H__
-#include "check/common.h"
+#include "check/mode-common.h"
#define ROOT_DIR_ERROR (1<<1) /* bad ROOT_DIR */
#define DIR_ITEM_MISSING (1<<2) /* DIR_ITEM not found */
diff --git a/check/original.h b/check/mode-original.h
index 0d9ab353..f859af47 100644
--- a/check/original.h
+++ b/check/mode-original.h
@@ -18,8 +18,9 @@
* Defines and function declarations for original mode check.
*/
-#ifndef __BTRFS_CHECK_ORIGINAL_H__
-#define __BTRFS_CHECK_ORIGINAL_H__
+#ifndef __BTRFS_CHECK_MODE_ORIGINAL_H__
+#define __BTRFS_CHECK_MODE_ORIGINAL_H__
+
#include "rbtree-utils.h"
struct extent_backref {