summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-04 18:10:23 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-04 18:10:23 +0100
commit779499a9addb90fa38597bba98523b1717982845 (patch)
tree48b3c441f32ad7f5c8ac71b7d869aaa4237bd475
parentf47834dd1bbb3aaf75d4e80fda07c528ef7dacfb (diff)
btrfs-progs: build, fix the source of btrfsck symlink
The installed symlink points to the absolute path of btrfs, a relative link is enough. Reported-by: WorMzy Tykashi <wormzy.tykashi@gmail.com> Signed-off-by: David Sterba <dsterba@suse.cz>
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 73983cc8..bd6fc349 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -318,7 +318,7 @@ install: $(libs) $(progs) $(INSTALLDIRS)
$(INSTALL) $(progs) $(DESTDIR)$(bindir)
$(INSTALL) fsck.btrfs $(DESTDIR)$(bindir)
# btrfsck is a link to btrfs in the src tree, make it so for installed file as well
- $(LN_S) -f $(DESTDIR)$(bindir)/btrfs $(DESTDIR)$(bindir)/btrfsck
+ $(LN_S) -f btrfs $(DESTDIR)$(bindir)/btrfsck
$(INSTALL) -m755 -d $(DESTDIR)$(libdir)
$(INSTALL) $(libs) $(DESTDIR)$(libdir)
cp -a $(lib_links) $(DESTDIR)$(libdir)