summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo Mills <h.r.mills@reading.ac.uk>2013-03-12 15:44:11 +0000
committerDavid Sterba <dsterba@suse.cz>2013-03-14 23:08:44 +0100
commit84a42b7c7145dcd3e7404e5a8180b1c5ddca530e (patch)
treeef4d2c132eca108867e815d5874b7f4baf5c1f29
parent7a355379ea93856cd90d01216dde8610a225b8aa (diff)
btrfs-progs: add Makefile rule for static build of btrfs-find-root
btrfs-find-root isn't yet integrated into the main btrfs tool, and is an important recovery tool, so it deserves to be built as a static binary. Signed-off-by: Hugo Mills <hugo@carfax.org.uk>
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 55ff5b4c..f65bb15c 100644
--- a/Makefile
+++ b/Makefile
@@ -86,7 +86,7 @@ all: version.h $(progs) manpages
# NOTE: For static compiles, you need to have all the required libs
# static equivalent available
#
-static: version.h $(libs) btrfs.static mkfs.btrfs.static
+static: version.h $(libs) btrfs.static mkfs.btrfs.static btrfs-find-root.static
version.h:
$(Q)bash version.sh
@@ -122,6 +122,10 @@ btrfs-find-root: $(objects) $(libs) find-root.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o btrfs-find-root find-root.o $(objects) $(LDFLAGS) $(LIBS)
+btrfs-find-root.static: $(static_objects) find-root.static.o
+ @echo " [LD] $@"
+ $(Q)$(CC) $(STATIC_CFLAGS) -o btrfs-find-root.static find-root.static.o $(static_objects) $(STATIC_LDFLAGS) $(STATIC_LIBS)
+
btrfsctl: $(objects) $(libs) btrfsctl.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)