summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-08-25 20:09:34 +0200
committerDavid Sterba <dsterba@suse.com>2017-09-08 16:15:05 +0200
commitb8c9c457c125718cdd2a25d876d8dac747f06f01 (patch)
tree8699d35c33f82ff36628cb6b4b2b7707ad903366
parent339019c93455ad8331e057e471d2c1ae6638e25d (diff)
btrfs-progs: build: properly pass the LDFLAGS during tsan build
The variable LD_FLAGS does not exist and the flags are not used, we need to use the newly added internal debugging linker flags. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f196198c..3d55203f 100644
--- a/Makefile
+++ b/Makefile
@@ -168,7 +168,7 @@ endif
ifneq (,$(findstring tsan,$(D)))
DEBUG_CFLAGS_INTERNAL += -fsanitize=thread -fPIE
- LD_FLAGS += -fsanitize=thread -ltsan -pie
+ DEBUG_LDFLAGS_INTERNAL += -fsanitize=thread -ltsan -pie
endif
ifneq (,$(findstring ubsan,$(D)))