summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2014-12-09 15:15:47 +0100
committerDavid Sterba <dsterba@suse.cz>2015-01-28 17:55:44 +0100
commitbb6b4fea9f78939262446e35d2e0d4d0ed0d8e57 (patch)
tree06d4c924de351af7ef787c4ea6f44bffd7c7b175
parent48e728d1120c9e5482b5e4aa4dd91f071acfd6bb (diff)
btrfs-progs: autoconf: use config.h
- the header file is generated by ./configure, the standard autotools way is to use -include config.h on compiler command line rather than include the file directly from code - remove _GNU_SOURCE from code, the macros is already defined in config.h by AC_USE_SYSTEM_EXTENSIONS autoconf macro Signed-off-by: Karel Zak <kzak@redhat.com> [_GNU_SOURCE changes already done] Signed-off-by: David Sterba <dsterba@suse.cz>
-rw-r--r--Makefile.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index dcd6a68c..c37db9dd 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -4,7 +4,11 @@ export
CC = gcc
LN = ln
AR = ar
-AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES -D_XOPEN_SOURCE=700 -D_GNU_SOURCE -fno-strict-aliasing -fPIC
+AM_CFLAGS = -include config.h -Wall \
+ -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES \
+ -D_XOPEN_SOURCE=700 \
+ -fno-strict-aliasing -fPIC
+CFLAGS = -g -O1 -fno-strict-aliasing -rdynamic
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o file-item.o inode-item.o inode-map.o \
extent-cache.o extent_io.o volumes.o utils.o repair.o \