summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2018-04-21 12:04:01 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2018-04-21 12:04:01 +0100
commitdab6d2181f1f194ec3a76d900cf2c6533379cbea (patch)
treeb47990a375ed0edf770a78906345ff63a1bc60be
parentb70cb0d0a21394d5d6b00b51f064115c2724cea8 (diff)
Dynamically detect and enable zstd support.debian/4.15.1-2archive/debian/4.15.1-2
-rw-r--r--debian/btrfs-progs.lintian-overrides4
-rw-r--r--debian/changelog13
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules8
4 files changed, 21 insertions, 5 deletions
diff --git a/debian/btrfs-progs.lintian-overrides b/debian/btrfs-progs.lintian-overrides
deleted file mode 100644
index 22abbb99..00000000
--- a/debian/btrfs-progs.lintian-overrides
+++ /dev/null
@@ -1,4 +0,0 @@
-# To avoid micro-packaging, btrfs-tools does contain its library in the same
-# package, therefore overwriting the following two lintian warnings.
-btrfs-progs: non-dev-pkg-with-shlib-symlink
-btrfs-progs: package-name-doesnt-match-sonames
diff --git a/debian/changelog b/debian/changelog
index b35695de..65be5d62 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+btrfs-progs (4.15.1-2) unstable; urgency=medium
+
+ * If libzstd is provided in both deb & udeb variants (such as Ubuntu
+ bionic) enable zstd support. If libzstd is not provided with both deb
+ & udeb variants (such as current Debian unstable) disable zstd
+ support. If and when libzstd is provided in both deb & udeb variants,
+ a binNMU of this package is sufficient to enable zstd support. Closes:
+ #886968
+ * Drop obsolete lintian overrides.
+ * Add alternative email address as uploader.
+
+ -- Dimitri John Ledkov <xnox@ubuntu.com> Sat, 21 Apr 2018 11:59:50 +0100
+
btrfs-progs (4.15.1-1) unstable; urgency=medium
* New upstream release
diff --git a/debian/control b/debian/control
index 51951d87..1114127f 100644
--- a/debian/control
+++ b/debian/control
@@ -2,6 +2,7 @@ Source: btrfs-progs
Section: admin
Priority: optional
Maintainer: Dimitri John Ledkov <xnox@debian.org>
+Uploaders: Dimitri John Ledkov <xnox@ubuntu.com>
Build-Depends: debhelper (>= 10),
e2fslibs-dev,
pkg-config,
diff --git a/debian/rules b/debian/rules
index d797ac8f..d5f052a5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,6 +12,8 @@ SHELL := sh -e
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
CFLAGS := $(patsubst -O2,-Os,$(CFLAGS))
+ZSTD := $(shell grep '^udeb: ' /var/lib/dpkg/info/libzstd*.shlibs)
+
%:
dh ${@} --with bash-completion
@@ -19,7 +21,11 @@ override_dh_autoreconf:
dh_autoreconf ./autogen.sh
override_dh_auto_configure:
- dh_auto_configure -- --bindir=/bin --disable-convert
+ifneq (,$(ZSTD))
+ dh_auto_configure -- --bindir=/bin --disable-convert --enable-zstd
+else
+ dh_auto_configure -- --bindir=/bin --disable-convert --disable-zstd
+endif
override_dh_auto_build:
dh_auto_build -- V=1