summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-05 15:11:40 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-05 15:11:40 +0100
commitdfbbe312ad367347c4b686bcd781a702eeef53da (patch)
tree01a00c7ea63bc4098cbcd9a5c16a3ebd16711119
parentf00d59d78f07e4f0428f4cd4e342a43eb0a99359 (diff)
btrfs-progs: autoconf: do not force fortify flags
Make it default, but let the user override it. Signed-off-by: David Sterba <dsterba@suse.cz>
-rw-r--r--Makefile.in2
-rw-r--r--configure.ac2
2 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index c233d3dd..36069013 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -132,10 +132,10 @@ ifdef C
# don't use FORTIFY with sparse because glibc with FORTIFY can
# generate so many sparse errors that sparse stops parsing,
# which masks real errors that we want to see.
+ CFLAGS += -U_FORTIFY_SOURCE
else
check = true
check_echo = true
- CFLAGS += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
endif
%.o.d: %.c
diff --git a/configure.ac b/configure.ac
index d059e1c7..0692d5a8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,7 +8,7 @@ LIBBTRFS_MAJOR=0
LIBBTRFS_MINOR=1
LIBBTRFS_PATCHLEVEL=1
-CFLAGS=${CFLAGS:-"-g -O1 -Wall"}
+CFLAGS=${CFLAGS:-"-g -O1 -Wall -D_FORTIFY_SOURCE=2"}
AC_SUBST([CFLAGS])
AC_PREREQ([2.60])