summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-10-07 11:55:50 +0200
committerDavid Sterba <dsterba@suse.com>2016-10-24 14:57:32 +0200
commite0c979343de42d0db2f63633892de55727c60926 (patch)
tree449d9cb2a005360d133d5312d6e3d4f44f3d7057
parent6f306e8d62f8cca23fcb3aa56b3594d1ac531359 (diff)
btrfs-progs: test: add default ioctl-test build
Add another target that'll use default compiler options, eg. if we don't know the bitness of the architecture or gcc does not recognize the -m32/-m64 options. Signed-off-by: David Sterba <dsterba@suse.com>
-rw-r--r--Makefile.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 844423d4..5187a936 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -392,6 +392,10 @@ quick-test: $(objects) $(libs) quick-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o quick-test $(objects) $(libs) quick-test.o $(LDFLAGS) $(LIBS)
+ioctl-test.o: ioctl-test.c ioctl.h kerncompat.h ctree.h
+ @echo " [CC] $@"
+ $(Q)$(CC) $(CFLAGS) -c $< -o $@
+
ioctl-test-32.o: ioctl-test.c ioctl.h kerncompat.h ctree.h
@echo " [CC32] $@"
$(Q)$(CC) $(CFLAGS) -m32 -c $< -o $@
@@ -400,6 +404,12 @@ ioctl-test-64.o: ioctl-test.c ioctl.h kerncompat.h ctree.h
@echo " [CC64] $@"
$(Q)$(CC) $(CFLAGS) -m64 -c $< -o $@
+ioctl-test: ioctl-test.o
+ @echo " [LD] $@"
+ $(Q)$(CC) $(CFLAGS) -o $@ $< $(LDFLAGS)
+ @echo " ?[PAHOLE] $@.pahole"
+ -$(Q)pahole $@ > $@.pahole
+
ioctl-test-32: ioctl-test-32.o
@echo " [LD32] $@"
$(Q)$(CC) $(CFLAGS) -m32 -o $@ $< $(LDFLAGS)
@@ -412,8 +422,9 @@ ioctl-test-64: ioctl-test-64.o
@echo " ?[PAHOLE] $@.pahole"
-$(Q)pahole $@ > $@.pahole
-test-ioctl: ioctl-test-32 ioctl-test-64
+test-ioctl: ioctl-test ioctl-test-32 ioctl-test-64
@echo " [TEST/ioctl]"
+ $(Q)./ioctl-test > ioctl-test.log
$(Q)./ioctl-test-32 > ioctl-test-32.log
$(Q)./ioctl-test-64 > ioctl-test-64.log