summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2016-07-26 13:44:30 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2016-07-26 13:44:30 +0100
commitb37383236dd3b1b261945f000ee4c5abd021c74d (patch)
treeb03fab7a3c4e30dbd512583b77c7b767a6a7f93d
parent70eda1446aee7b45fabbf4e4800a078fb1477e57 (diff)
Ship libgcc_s into the initrd, for scrub to work because it uses pthread_cancel. Thanks Guilhem. (Closes: #830883)
-rw-r--r--debian/changelog2
-rw-r--r--debian/local/btrfs.hook4
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3ba46db7..b9750c02 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ btrfs-progs (4.6.1-1) UNRELEASED; urgency=high
#824894)
* Set Vcs-* control headers pointing at dgit git repositories
* Add udev build-dependency, to install upstream btrfs-dm udev rules
+ * Ship libgcc_s into the initrd, for scrub to work because it uses
+ pthread_cancel. Thanks Guilhem. (Closes: #830883)
[ Nicholas D Steeves ]
* debian/watch: add mangling rules to prefer non-rcN versions; add
diff --git a/debian/local/btrfs.hook b/debian/local/btrfs.hook
index d31199cb..f4dbb9da 100644
--- a/debian/local/btrfs.hook
+++ b/debian/local/btrfs.hook
@@ -26,4 +26,8 @@ then
then
copy_exec /bin/fsck.btrfs /bin
fi
+ LIBC_DIR=$(ldd /bin/btrfs | sed -nr 's#.* => (/lib.*)/libc\.so\.[0-9.-]+ \(0x[[:xdigit:]]+\)$#\1#p')
+ find -L "$LIBC_DIR" -maxdepth 1 -name 'libgcc_s.*' -type f | while read so; do
+ copy_exec "$so"
+ done
fi