summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArnd Hannemann <arnd@arndnet.de>2011-12-01 11:33:21 -0500
committerChris Mason <chris.mason@oracle.com>2011-12-01 11:33:21 -0500
commitfdb6c0402337d9607c7a39155088eaf033742752 (patch)
tree5f889ea08ff6e02035f503228796e9ef45f7f411
parent6da41f2a740569440e88539779cb94f169b1f1b6 (diff)
Btrfs-progs: Relocate -lpthread in makefile
This patch fixes the following compile error when compiled with gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3): gcc -lpthread -g -O0 -o btrfs btrfs.o btrfs_cmds.o scrub.o \ ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o root-tree.o dir-item.o file-item.o inode-item.o inode-map.o crc32c.o rbtree.o extent-cache.o extent_io.o volumes.o utils.o btrfs-list.o btrfslabel.o -luuid scrub.o: In function `scrub_start': /home/arnd/Projekte/kernel/btrfs-progs/scrub.c:1342: undefined reference to `pthread_create' /home/arnd/Projekte/kernel/btrfs-progs/scrub.c:1360: undefined reference to `pthread_create' /home/arnd/Projekte/kernel/btrfs-progs/scrub.c:1374: undefined reference to `pthread_join' /home/arnd/Projekte/kernel/btrfs-progs/scrub.c:1430: undefined reference to `pthread_cancel' /home/arnd/Projekte/kernel/btrfs-progs/scrub.c:1432: undefined reference to `pthread_join' collect2: ld returned 1 exit status make: *** [btrfs] Error 1 The gcc man page says: "[...] the placement of the -l option is significant." so lets include -lpthread together with the usual $(LIBS) Signed-off-by: Arnd Hannemann <arnd@arndnet.de> Signed-off-by: Chris Mason <chris.mason@oracle.com>
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 96e20020..834be475 100644
--- a/Makefile
+++ b/Makefile
@@ -37,8 +37,8 @@ version:
bash version.sh
btrfs: $(objects) btrfs.o btrfs_cmds.o scrub.o
- $(CC) -lpthread $(CFLAGS) -o btrfs btrfs.o btrfs_cmds.o scrub.o \
- $(objects) $(LDFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) -o btrfs btrfs.o btrfs_cmds.o scrub.o \
+ $(objects) $(LDFLAGS) $(LIBS) -lpthread
calc-size: $(objects) calc-size.o
gcc $(CFLAGS) -o calc-size calc-size.o $(objects) $(LDFLAGS) $(LIBS)