summaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2017-07-31 14:54:24 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2017-07-31 14:54:24 +0100
commit6a0440391da7a99ffab94ccc66264af9b5f3ce34 (patch)
tree1c7cf4f07b08c4965ab19819ebce367be16fb980 /CHANGES
parent5f2e2384443a09e3f1fec71940e9e32b70789102 (diff)
New upstream release.
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES91
1 files changed, 77 insertions, 14 deletions
diff --git a/CHANGES b/CHANGES
index fcabe663..db24f7c6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,66 @@
+btrfs-progs-4.12 (2017-07-26)
+ * subvol show: new options --rootid, --uuid to show subvol by the given spec
+ * convert: progress report fixes, found by tsan
+ * image: progress report fixes, found by tsan
+ * fix infinite looping in find-root, or when looking for free extents
+ * other:
+ * code refactoring
+ * docs updates
+ * build: ThreadSanitizer support
+ * tests: stricter checks for mounted filesystem
+
+btrfs-progs-4.11.1 (2017-06-30)
+ * image: restoring from multiple devices
+ * dev stats: make --check option work
+ * check: fix false alert with extent hole on a NO_HOLE filesystem
+ * check: lowmem mode, fix false alert in case of mixed inline and compressed
+ extent
+ * convert: work with large filesystems (many TB)
+ * convert: fix overwriting of eb header flags
+ * convert: do not clear NODATASUM flag in inodes when run with --no-datasum
+ * docs updates
+ * build: sync Android.mk with Makefile
+ * tests:
+ * new tests
+ * fix 008 and 009, shell quotation mistake
+
+btrfs-progs-4.11 (2017-05-18)
+ * receive: fix handling empty stream with -e (multi-stream)
+ * send dump: fix printing long file names
+ * stability fixes for: dump-super, print-tree, check
+ * option parser updates: global options are parsed before the subcommand name
+ (old xfstests will fail)
+ * new and updated tests
+ * documentation updates
+
+btrfs-progs-4.10.2 (2017-03-31)
+ * check: lowmem mode fix for false alert about lost backrefs
+ * convert: minor bugfix
+ * library: fix build, misisng symbols, added tests
+
+btrfs-progs-4.10.1 (2017-03-17)
+ * receive: handle subvolume in path clone
+ * convert: rollback fixed (rewrite was needed to address previous design issues)
+ * build: fix build of 3rd party tools, missing <linux/sizes.h>
+ * dump-tree: print log trees
+ * other
+ * new and updated tests
+
+btrfs-progs-4.10 (2017-03-08)
+ * send: dump output fixes: missing newlies
+ * check: several fixes for the lowmem mode, improved error reporting
+ * build
+ * removed some library deps for binaries that not use them
+ * ctags, cscope
+ * split Makefile to the autotool generated part and the rest, not needed
+ to autogen.sh after adding a file
+ * shared code: sync easy parts with kernel sources
+ * other
+ * lots of cleanups
+ * source file reorganization: convert, mkfs, utils
+ * lots of spelling fixes in docs, other updates
+ * more tests
+
btrfs-progs-4.9.1 (2017-01-27)
* check:
* use correct inode number for lost+found files
@@ -169,7 +232,7 @@ btrfs-progs-4.7 (2016-07-29)
* more tests
btrfs-progs-4.6.1 (2016-06-24)
- * fi resize: negative resize argument accepted again
+ * filesystem resize: negative resize argument accepted again
* qgroup rescan: fix skipping when rescan is in progress
* mkfs: initialize stripesize to correct value
* testsuite updates, mostly convert tests
@@ -214,8 +277,8 @@ btrfs-progs-4.5.2 (2016-05-02)
* check: catch when qgroup numbers mismatch
* check: detect running quota rescan and report mismatches
* balance start: add safety delay before doing a full balance
- * fi sync: is now silent
- * fi show: don't miss filesystems with partially matching uuids
+ * filesystem sync: is now silent
+ * filesystem show: don't miss filesystems with partially matching uuids
* dev ready: accept only one argument for device
* dev stats: print "devid:N" for a missing device instead of "(null)"
* other:
@@ -232,7 +295,7 @@ btrfs-progs-4.5 (2016-03-20)
* btrfs-debug-tree -> btrfs inspect-internal dump-tree
New commands:
- * btrfs fi du - calculate disk usage, including shared extents
+ * btrfs filesystem du - calculate disk usage, including shared extents
Enhancements:
* device delete - delete by id (needs kernel support, not merged to
@@ -325,7 +388,7 @@ btrfs-progs-4.3 (2015-11-06)
* print version info earlier
* print devices sorted by id
* do not truncate target image with --rootsize
- * fi usage:
+ * filesystem usage:
* don't print global block reserve
* print device id
* minor output tuning
@@ -371,11 +434,11 @@ btrfs-progs-4.2.3 (2015-10-19)
* restore: off-by-one symlink path check fix
btrfs-progs-4.2.2 (2015-10-05)
- * fi label: use fallback if the label ioctl is not available
+ * filesystem label: use fallback if the label ioctl is not available
* convert: check nodesize constraints against commandline features (-O)
* scrub: report status 'running' until all devices are finished
* device scanning might crash in some scenarios
- * fi usage: print summary for non-root users
+ * filesystem usage: print summary for non-root users
btrfs-progs-4.2.1 (2015-09-20)
* fix an off-by-one error in cross-stripe boundary check
@@ -534,7 +597,7 @@ btrfs-progs-3.19.1 (2015-03-25)
* build fixes:
* missing macro from public header, BTRFS_BUILD_VERSION
* wrong handling of --enable-convert
- * fi usage: reports correct space for degraded mounts
+ * filesystem usage: reports correct space for degraded mounts
* other:
* mkfs: help string updates
* completion: added 'usage' subcommands
@@ -558,7 +621,7 @@ btrfs-progs-3.18.2 (2015-01-27)
* qgroup show: print human readable sizes, options to say otherwise
* check: new option to explicitly say no to writes
* mkfs: message about trimming is not printed to stderr
- * fi show: fixed return value
+ * filesystem show: fixed return value
* tests: new infrastructure
* btrfstune: force flag can be used together with seeding option
* backtrace support is back
@@ -573,7 +636,7 @@ btrfs-progs-3.18 (2014-12-30)
* mkfs - skinny-metadata feature is now on by default, first introduced in
kernel 3.10
* filesystem usage - give an overview of fs usage in a way that's more
- comprehensible than existing 'fi df'
+ comprehensible than existing 'filesystem df'
* device usage - more detailed information about per-device allocations
* check
* option to set a different tree root byte number
@@ -600,12 +663,12 @@ btrfs-progs-3.17.2 (2014-11-19)
* zero-log: able to reset a fs with bogus log tree pointer (bug_72151)
btrfs-progs-3.17.1 (2014-11-04)
- * fi df: argument handling
+ * filesystem df: argument handling
* fix linking with libbtrfs
* replace: better error reporting
- * fi show: fixed stall if run concurrently with balance
+ * filesystem show: fixed stall if run concurrently with balance
* check: fixed argument parsing for --subvol-extents
- * fi df: SI prefixes corrected
+ * filesystem df: SI prefixes corrected
btrfs-progs-3.17 (2014-10-17)
* check: --init-csum-tree actually does something useful, rebuilds the
@@ -620,7 +683,7 @@ btrfs-progs-3.16.2 (2014-10-01)
* a few fixes in fsck and image tools
btrfs-progs-3.16.1 (2014-09-15)
- * print GlobalReserve in fi df output
+ * print GlobalReserve in filesystem df output
* new option -R in subvol list
* library version defines
* static build is fixed