summaryrefslogtreecommitdiff
path: root/Documentation/Makefile.in
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-08-06 16:54:31 -0400
committerDavid Sterba <dsterba@suse.com>2018-10-23 14:48:39 +0200
commit14357b3e340f8e57e922e6c08f5fb621dce77aff (patch)
tree757c066fdba35c2272b7e8b0b06a2adee2ba9b1d /Documentation/Makefile.in
parentc0bf61709bd227b6358a6b3f10526e1ba7f950c6 (diff)
btrfs-progs: docs: install uncompressed manual pages
Build systems do not typically compress man pages when installing them. This is generally left to distro packaging mechanisms, which may end up recompressing them using a different compressor. Author: Mike Gilbert <floppym@gentoo.org> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Documentation/Makefile.in')
-rw-r--r--Documentation/Makefile.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/Documentation/Makefile.in b/Documentation/Makefile.in
index 83968e08..c0467c91 100644
--- a/Documentation/Makefile.in
+++ b/Documentation/Makefile.in
@@ -37,9 +37,9 @@ MAN3_TXT += btrfs-ioctl.asciidoc
MAN_TXT = $(MAN3_TXT) $(MAN8_TXT) $(MAN5_TXT)
MAN_XML = $(patsubst %.asciidoc,%.xml,$(MAN_TXT))
MAN_HTML = $(patsubst %.asciidoc,%.html,$(MAN_TXT))
-GZ_MAN3 = $(patsubst %.asciidoc,%.3.gz,$(MAN3_TXT))
-GZ_MAN5 = $(patsubst %.asciidoc,%.5.gz,$(MAN5_TXT))
-GZ_MAN8 = $(patsubst %.asciidoc,%.8.gz,$(MAN8_TXT))
+MAN3 = $(patsubst %.asciidoc,%.3,$(MAN3_TXT))
+MAN5 = $(patsubst %.asciidoc,%.5,$(MAN5_TXT))
+MAN8 = $(patsubst %.asciidoc,%.8,$(MAN8_TXT))
mandir ?= $(prefix)/share/man
man3dir = $(mandir)/man3
@@ -86,9 +86,9 @@ endif
all: man
man: man3 man5 man8
-man3: $(GZ_MAN3)
-man5: $(GZ_MAN5)
-man8: $(GZ_MAN8)
+man3: $(MAN3)
+man5: $(MAN5)
+man8: $(MAN8)
html: $(MAN_HTML)
install: install-man
@@ -96,15 +96,15 @@ install: install-man
install-man: man
$(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
$(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
- $(INSTALL) -m 644 $(GZ_MAN5) $(DESTDIR)$(man5dir)
+ $(INSTALL) -m 644 $(MAN5) $(DESTDIR)$(man5dir)
# the source file name of btrfs.5 clashes with section 8 page, but we
# want to keep the code generic
- $(MV) $(DESTDIR)$(man5dir)/btrfs-man5.5.gz $(DESTDIR)$(man5dir)/btrfs.5.gz
- $(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
+ $(MV) $(DESTDIR)$(man5dir)/btrfs-man5.5 $(DESTDIR)$(man5dir)/btrfs.5
+ $(INSTALL) -m 644 $(MAN8) $(DESTDIR)$(man8dir)
$(INSTALL) -m 644 btrfsck.8 $(DESTDIR)$(man8dir)
uninstall:
- cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8.gz $(GZ_MAN8)
+ cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8 $(MAN8)
$(RMDIR) -p --ignore-fail-on-non-empty $(DESTDIR)$(man8dir)
clean: