summaryrefslogtreecommitdiff
path: root/Documentation/Makefile
diff options
context:
space:
mode:
authorEric Sandeen <sandeen@redhat.com>2014-06-11 17:14:55 -0500
committerDavid Sterba <dsterba@suse.cz>2014-08-22 14:39:34 +0200
commit26341f734d6d16b5025616f8ad83755512ac996e (patch)
tree8cfbb71144f608423d9a2387cae4043f541edd4e /Documentation/Makefile
parent8559a1626f6e36d32b07925d35824593eb2b0380 (diff)
btrfs-progs: add mount options to btrfs-mount.5
This is a straight cut and paste from the util-linux mount manpage into btrfs-mount.5 It's pretty much impossible for util-linux to keep up with every filesystem out there, and Karel has more than once expressed a wish that mount options move into fs-specific manpages. So, here we go. The way btrfs asciidoc is generated, there's not a trivial way to have both btrfs(5) and btrfs(8) so I named it btrfs-mount(5) for now. A bit ick and I'm open to suggestions. Signed-off-by: Eric Sandeen <sandeen@redhat.com> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Documentation/Makefile')
-rw-r--r--Documentation/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index 0ff81da3..f1a07a2d 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -31,13 +31,21 @@ MAN8_TXT += btrfs-replace.txt
MAN8_TXT += btrfs-restore.txt
MAN8_TXT += btrfs-property.txt
-MAN_TXT = $(MAN8_TXT)
+# Mount manpage
+MAN5_TXT += btrfs-mount.txt
+
+MAN_TXT = $(MAN8_TXT) $(MAN5_TXT)
MAN_XML = $(patsubst %.txt,%.xml,$(MAN_TXT))
+
+DOC_MAN5 = $(patsubst %.txt,%.5,$(MAN5_TXT))
+GZ_MAN5 = $(patsubst %.txt,%.5.gz,$(MAN5_TXT))
+
DOC_MAN8 = $(patsubst %.txt,%.8,$(MAN8_TXT))
GZ_MAN8 = $(patsubst %.txt,%.8.gz,$(MAN8_TXT))
mandir ?= $(prefix)/share/man
man8dir = $(mandir)/man8
+man5dir = $(mandir)/man5
ASCIIDOC = asciidoc
ASCIIDOC_EXTRA =
@@ -67,25 +75,36 @@ endif
endif
all: man
-man: man8
+man: man5 man8
+man5: $(GZ_MAN5)
man8: $(GZ_MAN8)
install: install-man
install-man: man
+ $(INSTALL) -d -m 755 $(DESTDIR)$(man5dir)
$(INSTALL) -d -m 755 $(DESTDIR)$(man8dir)
+ $(INSTALL) -m 644 $(GZ_MAN5) $(DESTDIR)$(man5dir)
$(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
$(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
clean:
- $(QUIET_RM)$(RM) *.xml *.xml+ *.8 *.8.gz
+ $(QUIET_RM)$(RM) *.xml *.xml+ *.5 *.5.gz *.8 *.8.gz
+
+%.5.gz : %.5
+ $(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
%.8.gz : %.8
$(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
+%.5 : %.xml
+ $(QUIET_XMLTO)$(RM) $@ && \
+ $(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man $<
+
%.8 : %.xml
$(QUIET_XMLTO)$(RM) $@ && \
$(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man $<
+
%.xml : %.txt asciidoc.conf
$(QUIET_ASCIIDOC)$(RM) $@.tmp[12] $@ && \
sed -e "s/\(<[^>]\+>\)/'\1'/g" < $< > $@.tmp1 && \