summaryrefslogtreecommitdiff
path: root/Documentation
diff options
context:
space:
mode:
authorChristian Hesse <mail@eworm.de>2014-06-03 08:09:25 +0200
committerDavid Sterba <dsterba@suse.cz>2014-08-22 14:39:31 +0200
commitd339d863ad5333c630ef14517f8dbfe11eb3904d (patch)
treeb717752f5920cbad1f9296179ff3eaaeb9572108 /Documentation
parent602aac5dbf0c3686c7473dfb025ca56ed13e2414 (diff)
btrfs-progs: fix build, manpage compression command
man pages for btrfs-progs are compressed by gzip by default. In Makefile the variable GZIP is use, this evaluates to 'gzip gzip' on my system. >From man gzip: > The environment variable GZIP can hold a set of default options for > gzip. These options are interpreted first and can be overwritten by > explicit command line parameters. So using any other variable name fixes this. Signed-off-by: Christian Hesse <mail@eworm.de> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Documentation')
-rw-r--r--Documentation/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index 45299bb2..3ee688bf 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -45,7 +45,7 @@ MANPAGE_XSL = manpage-normal.xsl
XMLTO = xmlto
XMLTO_EXTRA =
XMLTO_EXTRA = -m manpage-bold-literal.xsl
-GZIP = gzip
+GZIPCMD = gzip
INSTALL ?= install
RM ?= rm -f
LNS ?= ln -sf
@@ -80,9 +80,9 @@ clean:
$(RM) *.xml *.xml+ *.8 *.8.gz
%.8.gz : %.8
- $(QUIET_GZIP)$(GZIP) -n -c $< > $@
+ $(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
-%.8 : %.xml
+%.8 : %.xml
$(QUIET_XMLTO)$(RM) $@ && \
$(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man $<
%.xml : %.txt asciidoc.conf