summaryrefslogtreecommitdiff
path: root/Documentation
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-03 14:40:33 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-03 14:41:00 +0100
commit42e4dfe7722bd22bfa9251179190583e1eb4881e (patch)
tree6d947a30a0edd0001567ca784709312efd5739f6 /Documentation
parentccdd0a067f36b689a0928074d53e5020f3ff5f5d (diff)
btrfs-progs: build, fix rules to clean temporary files in docs
$ make clean-doc Cleaning Documentation /usr/bin/rm: cannot remove ‘*.xml’: No such file or directory /usr/bin/rm: cannot remove ‘*.xml+’: No such file or directory /usr/bin/rm: cannot remove ‘*.5’: No such file or directory /usr/bin/rm: cannot remove ‘*.8’: No such file or directory make[1]: *** [clean] Error 1 make: *** [clean-doc] Error 2 The RM variable from parent makefile lacks -f, add it where it's missing. Minor change in LN_S variable name, same -f change. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Documentation')
-rw-r--r--Documentation/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Documentation/Makefile b/Documentation/Makefile
index 72ab77bb..9466710c 100644
--- a/Documentation/Makefile
+++ b/Documentation/Makefile
@@ -55,8 +55,8 @@ XMLTO_EXTRA =
XMLTO_EXTRA = -m manpage-bold-literal.xsl
GZIPCMD = gzip
INSTALL ?= install
-RM ?= rm -f
-LNS ?= ln -sf
+RM ?= rm
+LN_S ?= ln -s
BTRFS_VERSION = $(shell sed -n 's/.*BTRFS_BUILD_VERSION "Btrfs \(.*\)"/\1/p'\
../version.h)
@@ -89,14 +89,14 @@ install-man: man
# want to keep the code generic
mv $(DESTDIR)$(man5dir)/btrfs-mount.5.gz $(DESTDIR)$(man5dir)/btrfs.5.gz
$(INSTALL) -m 644 $(GZ_MAN8) $(DESTDIR)$(man8dir)
- $(LNS) btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
+ $(LN_S) -f btrfs-check.8.gz $(DESTDIR)$(man8dir)/btrfsck.8.gz
uninstall:
cd $(DESTDIR)$(man8dir); rm -f btrfs-check.8.gz $(GZ_MAN8)
rmdir -p --ignore-fail-on-non-empty $(DESTDIR)$(man8dir)
clean:
- $(QUIET_RM)$(RM) *.xml *.xml+ *.5 *.5.gz *.8 *.8.gz
+ $(QUIET_RM)$(RM) -f *.xml *.xml+ *.5 *.5.gz *.8 *.8.gz
%.5.gz : %.5
$(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
@@ -105,15 +105,15 @@ clean:
$(QUIET_GZIP)$(GZIPCMD) -n -c $< > $@
%.5 : %.xml
- $(QUIET_XMLTO)$(RM) $@ && \
+ $(QUIET_XMLTO)$(RM) -f $@ && \
$(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man $<
%.8 : %.xml
- $(QUIET_XMLTO)$(RM) $@ && \
+ $(QUIET_XMLTO)$(RM) -f $@ && \
$(XMLTO) -m $(MANPAGE_XSL) $(XMLTO_EXTRA) man $<
%.xml : %.txt asciidoc.conf
- $(QUIET_ASCIIDOC)$(RM) $@+ $@ && \
+ $(QUIET_ASCIIDOC)$(RM) -f $@+ $@ && \
$(ASCIIDOC) -b docbook -d manpage -f asciidoc.conf \
$(ASCIIDOC_EXTRA) -abtrfs_version=$(BTRFS_VERSION) \
-o $@+ $< && \