summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-05 14:46:47 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-05 15:05:21 +0100
commit005526d065b73ee70a0a74223770e4dd2e7e1de2 (patch)
tree58676e21162eb126a6f4451a217c9509b7c90266 /Makefile.in
parent9143fda114c0f57bc57ca30378874f100cb1af73 (diff)
btrfs-progs: autoconf: move custom CFLAGS from makefile
Keep only flags that are required to build properly, current fine tunings are moved to the optional defaults in configure and can be overriden by the user. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index f3da51d8..0b92844b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -10,12 +10,14 @@ INSTALL = @INSTALL@
DISABLE_DOCUMENTATION = @DISABLE_DOCUMENTATION@
DISABLE_BTRFSCONVERT = @DISABLE_BTRFSCONVERT@
-# Non-static compilation flags
+# Common build flags
CFLAGS = @CFLAGS@ \
- -include config.h -Wall \
- -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES \
+ -include config.h \
+ -D_FILE_OFFSET_BITS=64 \
+ -DBTRFS_FLAT_INCLUDES \
-D_XOPEN_SOURCE=700 \
- -fno-strict-aliasing -fPIC \
+ -fno-strict-aliasing \
+ -fPIC \
-rdynamic
LDFLAGS = @LDFLAGS@