summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorNoah Massey <noah.massey@gmail.com>2016-03-21 10:16:07 -0400
committerDavid Sterba <dsterba@suse.com>2016-03-30 16:22:47 +0200
commit74a5d7478a5c0035df53823ba0c9167fce59f5e2 (patch)
tree1082e941ec5eb7b45304c9cdcef7ff922ceca41c /Makefile.in
parent03142f99bb4062835134200a9ca25d736cd0fe96 (diff)
btrfs-progs: build: fix static standalone utilities
commit b5e7979 "btrfs-progs: build: extend per-binary objects" allows the standalone utilities to link against object files shared with the main binary. However, the btrfs-*.static targets need to be adjusted to build against the static versions of the common files. Signed-off-by: Noah Massey <noah.massey@gmail.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index dd306862..c553c5f0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -254,7 +254,7 @@ $(lib_links):
btrfs-%.static: $(static_objects) btrfs-%.static.o $(static_libbtrfs_objects)
@echo " [LD] $@"
$(Q)$(CC) $(STATIC_CFLAGS) -o $@ $@.o $(static_objects) \
- $($(subst -,_,$(subst .static,,$@)-objects)) \
+ $(patsubst %.o, %.static.o, $($(subst -,_,$(subst .static,,$@)-objects))) \
$(static_libbtrfs_objects) $(STATIC_LDFLAGS) \
$($(subst -,_,$(subst .static,,$@)-libs)) $(STATIC_LIBS)