summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-10-06 12:56:02 +0200
committerDavid Sterba <dsterba@suse.com>2016-10-10 09:46:24 +0200
commit01ddfdbbcbb353815a912ceef560bd146d90fe5e (patch)
tree0e8e5afc7e0a121b235925388f71669439b377e9 /Makefile.in
parent81f4d96f3d6368dc4e5edf7e3cb9d19bb4d00c4f (diff)
btrfs-progs: build: add explicit option separator to rm commands
Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.in b/Makefile.in
index 86a35006..983b8b9a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -425,7 +425,7 @@ clean-all: clean clean-doc clean-gen
clean: $(CLEANDIRS)
@echo "Cleaning"
- $(Q)$(RM) -f $(progs) cscope.out *.o *.o.d \
+ $(Q)$(RM) -f -- $(progs) cscope.out *.o *.o.d \
kernel-lib/*.o kernel-lib/*.o.d \
dir-test ioctl-test quick-test send-test library-test library-test-static \
btrfs.static mkfs.btrfs.static \
@@ -439,7 +439,7 @@ clean-doc:
clean-gen:
@echo "Cleaning Generated Files"
- $(Q)$(RM) -rf version.h config.status config.cache connfig.log \
+ $(Q)$(RM) -rf -- version.h config.status config.cache connfig.log \
configure.lineno config.status.lineno Makefile \
Documentation/Makefile \
config.log config.h config.h.in~ aclocal.m4 \
@@ -477,10 +477,10 @@ $(INSTALLDIRS):
uninstall:
$(Q)$(MAKE) $(MAKEOPTS) -C Documentation uninstall
- cd $(DESTDIR)$(incdir); $(RM) -f $(headers)
- $(RMDIR) -p --ignore-fail-on-non-empty $(DESTDIR)$(incdir)
- cd $(DESTDIR)$(libdir); $(RM) -f $(lib_links) $(libs)
- cd $(DESTDIR)$(bindir); $(RM) -f btrfsck fsck.btrfs $(progs_install)
+ cd $(DESTDIR)$(incdir); $(RM) -f -- $(headers)
+ $(RMDIR) -p --ignore-fail-on-non-empty -- $(DESTDIR)$(incdir)
+ cd $(DESTDIR)$(libdir); $(RM) -f -- $(lib_links) $(libs)
+ cd $(DESTDIR)$(bindir); $(RM) -f -- btrfsck fsck.btrfs $(progs_install)
ifneq ($(MAKECMDGOALS),clean)
-include $(objects:.o=.o.d) $(cmds_objects:.o=.o.d) $(subst .btrfs,, $(filter-out btrfsck.o.d, $(progs:=.o.d)))