summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDimitri John Ledkov <xnox@ubuntu.com>2016-09-08 12:29:10 +0100
committerDimitri John Ledkov <xnox@ubuntu.com>2016-09-08 12:29:10 +0100
commit249a3592d5dfdec0e52b5e9e712339364ea758ed (patch)
tree54a81f37cfdccbb5ba1d3c925e6fd9261311550e /Makefile.in
parentca0dc13dd212ef8ca19fa6128115fe933b055437 (diff)
New upstream release. (Closes: #836778)debian/4.7.2-1
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 5c0c0d06..fd68b3ee 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -17,6 +17,7 @@
# trace - print trace before the error/warning messages
# abort - call abort() on first error (dumps core)
# all - shortcut for all of the above
+# asan - enable address sanitizer compiler feature
# W=123 build with warnings (default: off)
# DEBUG_CFLAGS additional compiler flags for debugging build
# EXTRA_CFLAGS additional compiler flags
@@ -145,6 +146,10 @@ ifneq (,$(findstring all,$(D)))
DEBUG_CFLAGS_INTERNAL += -DDEBUG_ABORT_ON_ERROR=1
endif
+ifneq (,$(findstring asan,$(D)))
+ DEBUG_CFLAGS_INTERNAL += -fsanitize=address
+endif
+
MAKEOPTS = --no-print-directory Q=$(Q)
# build all by default