summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-01-21 10:59:32 -0500
committerDavid Sterba <dsterba@suse.com>2016-01-21 19:35:33 +0100
commit30ce6c76c14621e1063039a690fc77dd09f78243 (patch)
tree9be3cb76306342b434bde9c6ea8b118395099add /Makefile.in
parent21258fab2caeade405a15ba932d373b364aa6e8c (diff)
btrfs-progs: Makefile.in: Simplify/correct install-static
install -D does not create the last component, so this failed if $(DESTDIR)$(bindir) did not already exist. There's no need for a loop here since install accepts multiple source arguments. Signed-off-by: Mike Gilbert <floppym@gentoo.org> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 19697ffa..82a3143c 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -379,9 +379,8 @@ install: $(libs) $(progs_install) $(INSTALLDIRS)
$(INSTALL) -m644 $(headers) $(DESTDIR)$(incdir)
install-static: $(progs_static) $(INSTALLDIRS)
- for p in $(progs_static) ; do \
- $(INSTALL) -D -m755 $$p $(DESTDIR)$(bindir)/ ; \
- done
+ $(INSTALL) -m755 -d $(DESTDIR)$(bindir)
+ $(INSTALL) $(progs_static) $(DESTDIR)$(bindir)
# btrfsck is a link to btrfs in the src tree, make it so for installed file as well
$(LN_S) -f btrfs.static $(DESTDIR)$(bindir)/btrfsck.static