summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-01-28 18:16:10 +0100
committerDavid Sterba <dsterba@suse.cz>2015-01-28 18:16:10 +0100
commit5989e9dd50fb5f6fcf2a0141f66688896c44894d (patch)
treecb546e50930d573df1883d00bebb39ff4ed95a35 /Makefile.in
parentbadb4a15af485adef36a2f9604199a4e81eb2aa8 (diff)
btrfs-progs: build, make build test work again
We need to regenerate version.h after clean-all. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index d3753fa3..8efabbf9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -260,8 +260,14 @@ library-test.static: $(libs_static) library-test.o
@echo " [LD] $@"
$(Q)$(CC) $(CFLAGS) -o library-test-static library-test.o $(LDFLAGS) $(libs_static)
-test-build:
+test-build: test-build-pre test-build-real
+
+test-build-pre:
$(MAKE) clean-all
+ ./autogen.sh
+ ./configure
+
+test-build-real:
$(MAKE) library-test
-$(MAKE) library-test.static
$(MAKE) -j 8 all