summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2015-10-26 14:35:34 +0100
committerDavid Sterba <dsterba@suse.com>2015-11-02 09:35:07 +0100
commitb85c7b76949017234ccc6ceafe503cc50917ebd2 (patch)
tree427c9f54da42a18923650019475e040cb2bc92a1 /Makefile.in
parentaa075c07c09a1d8f36e7a62d6db173d29068624d (diff)
btrfs-progs: tests: add test driver for fuzzed images
Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index cc6ed59f..8e248086 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -205,11 +205,15 @@ test-mkfs: btrfs mkfs.btrfs
@echo " [TEST] mkfs-tests.sh"
$(Q)bash tests/mkfs-tests.sh
+test-fuzz: btrfs
+ @echo " [TEST] fuzz-tests.sh"
+ $(Q)bash tests/fuzz-tests.sh
+
test-clean:
@echo "Cleaning tests"
$(Q)bash tests/clean-tests.sh
-test: test-fsck test-mkfs test-convert test-misc
+test: test-fsck test-mkfs test-convert test-misc test-fuzz
#
# NOTE: For static compiles, you need to have all the required libs