summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-02-05 15:11:40 +0100
committerDavid Sterba <dsterba@suse.cz>2015-02-05 15:11:40 +0100
commitdfbbe312ad367347c4b686bcd781a702eeef53da (patch)
tree01a00c7ea63bc4098cbcd9a5c16a3ebd16711119 /Makefile.in
parentf00d59d78f07e4f0428f4cd4e342a43eb0a99359 (diff)
btrfs-progs: autoconf: do not force fortify flags
Make it default, but let the user override it. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index c233d3dd..36069013 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -132,10 +132,10 @@ ifdef C
# don't use FORTIFY with sparse because glibc with FORTIFY can
# generate so many sparse errors that sparse stops parsing,
# which masks real errors that we want to see.
+ CFLAGS += -U_FORTIFY_SOURCE
else
check = true
check_echo = true
- CFLAGS += -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
endif
%.o.d: %.c