summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-11-24 11:30:06 +0100
committerDavid Sterba <dsterba@suse.com>2016-11-24 13:06:36 +0100
commite11315343f7b91440aacaf5bc42c691ae0dd96ff (patch)
tree84e82b24ce400ced6224c87380f32e017237c639 /Makefile.in
parent15f2582e5440b4e67ec6e631a6915ec31b383f7f (diff)
btrfs-progs: build: link against local libraries
If there's a system provided libbtrfs.0, it will be used for the library-test build and could miss linker errors, as reported. Reported-by: Mike Gilbert <floppymaster@gmail.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.in b/Makefile.in
index 79dfcf5a..240df7a0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -73,7 +73,7 @@ CFLAGS = @CFLAGS@ \
$(EXTRA_CFLAGS)
LDFLAGS = @LDFLAGS@ \
- -rdynamic $(EXTRA_LDFLAGS)
+ -rdynamic -L$(TOPDIR) $(EXTRA_LDFLAGS)
LIBS = @UUID_LIBS@ @BLKID_LIBS@ @ZLIB_LIBS@ @LZO2_LIBS@ -L. -pthread
LIBBTRFS_LIBS = $(LIBS)