summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.cz>2015-04-07 18:29:05 +0200
committerDavid Sterba <dsterba@suse.cz>2015-04-07 18:36:59 +0200
commit047dd1bf5d6c7d8cb92e2d94d1f4eca15f14152b (patch)
treee1c71b5827d59efa8439119b539b9c42ae786a0a /Makefile.in
parent35d53302ac961d8d7706318f9d6d12282f712703 (diff)
btrfs-progs: tests: split make rule for fsck and convert tests, fix prerequisities
We'd like to run each class of tests separately. There were some missing prerequisities that should be/are verified by the tests, makefile rules have been synced. Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/Makefile.in b/Makefile.in
index 83927e48..3c50613e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -161,11 +161,15 @@ $(BUILDDIRS):
@echo "Making all in $(patsubst build-%,%,$@)"
$(Q)$(MAKE) $(MAKEOPTS) -C $(patsubst build-%,%,$@)
-test: btrfs btrfs-convert btrfs-image btrfs-corrupt-block
- $(Q)for t in $(TESTS); do \
- echo " [TEST] $$t"; \
- bash tests/$$t || exit 1; \
- done
+test-convert: btrfs btrfs-convert
+ @echo " [TEST] convert-tests.sh"
+ $(Q)bash tests/convert-tests.sh
+
+test-fsck: btrfs btrfs-image btrfs-corrupt-block btrfs-debug-tree mkfs.btrfs
+ @echo " [TEST] fsck-tests.sh"
+ $(Q)bash tests/fsck-tests.sh
+
+test: test-fsck test-convert
#
# NOTE: For static compiles, you need to have all the required libs