summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2015-08-31 18:36:16 +0200
committerDavid Sterba <dsterba@suse.com>2015-09-01 14:02:50 +0200
commit123f4bc78c6f62c49f841667884e87e7e39e307f (patch)
treef85582d8a070fee2049d5e110b064184a88b964e /Makefile.in
parent0cdee628b11d53db814dbfa3c9e4f874f83c535c (diff)
btrfs-progs: makefile: add support for additional build flags
Allow fine tuned build options via EXTRA_CFLAGS and EXTRA_LDFLAGS variables. Useful for additional debugging flags or warnings etc. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 25b4038a..665f83c0 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -10,16 +10,19 @@ INSTALL = @INSTALL@
DISABLE_DOCUMENTATION = @DISABLE_DOCUMENTATION@
DISABLE_BTRFSCONVERT = @DISABLE_BTRFSCONVERT@
+EXTRA_CFLAGS :=
+EXTRA_LDFLAGS :=
+
# Common build flags
CFLAGS = @CFLAGS@ \
-include config.h \
-DBTRFS_FLAT_INCLUDES \
-D_XOPEN_SOURCE=700 \
-fno-strict-aliasing \
- -fPIC
+ -fPIC $(EXTRA_CFLAGS)
LDFLAGS = @LDFLAGS@ \
- -rdynamic
+ -rdynamic $(EXTRA_LDFLAGS)
LIBS = @UUID_LIBS@ @BLKID_LIBS@ @ZLIB_LIBS@ @LZO2_LIBS@ -L. -pthread
LIBBTRFS_LIBS = $(LIBS)