summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-11-18 15:18:02 +0100
committerDavid Sterba <dsterba@suse.com>2016-11-23 10:51:43 +0100
commit4884ae2f5e87e1cfbf7cc1d5624e0600b1fa46b3 (patch)
tree079104e1620feb45b498bac00f1218ec868252d2 /Makefile.in
parent7cd40e125b42831f1cda999a5d206739853120fd (diff)
btrfs-progs: tests: enhance TEST_LOG features
Add new keyword to dump the log file after any test fails. Can be useful for remote analysis of test failures. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 4bd3e63d..cba8f362 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -25,6 +25,11 @@
# EXTRA_CFLAGS additional compiler flags
# EXTRA_LDFLAGS additional linker flags
#
+# Testing-specific options (see also tests/README.md):
+# TEST=GLOB run test(s) from directories matching GLOB
+# TEST_LOG=tty print name of a command run via the execution helpers
+# TEST_LOG=dump dump testing log file when a test fails
+#
# Static checkers:
# CHECKER static checker binary to be called (default: sparse)
# CHECKER_FLAGS flags to pass to CHECKER, can override CFLAGS