summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-05-19 14:20:51 +0200
committerDavid Sterba <dsterba@suse.com>2016-06-01 14:56:56 +0200
commit6a0d3bf28d42b9b4249056b213636952d4575ace (patch)
tree43bf6585cb4713cebe1eabd257648279ed01e97c /Makefile.in
parent98410fce1d4c9ca309a4460f251489d65af3fe52 (diff)
btrfs-progs: makefile: add target for testing installation
Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 6febd94e..ac6b353b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -242,6 +242,12 @@ test-clean:
@echo "Cleaning tests"
$(Q)bash tests/clean-tests.sh
+test-inst: all
+ @tmpdest=`mktemp --tmpdir -d btrfs-inst.XXXXXX` && \
+ echo "Test installation to $$tmpdest" && \
+ $(MAKE) DESTDIR=$$tmpdest install && \
+ $(RM) -rf -- $$tmpdest
+
test: test-fsck test-mkfs test-convert test-misc test-fuzz
#