summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-09-03 21:36:53 +0200
committerDavid Sterba <dsterba@suse.com>2016-09-05 12:20:24 +0200
commit857e55ab024a071565817ad2e72cbf0d1b52d71d (patch)
treec76e6905fd10567e7947186098ce94bc33265b9f /Makefile.in
parent7d6307dcf3dbbb5bd9a9aafad77b8393c73b2618 (diff)
btrfs-progs: build: add ASAN to debugging features
usage: make D=asan Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 5c0c0d06..fd68b3ee 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -17,6 +17,7 @@
# trace - print trace before the error/warning messages
# abort - call abort() on first error (dumps core)
# all - shortcut for all of the above
+# asan - enable address sanitizer compiler feature
# W=123 build with warnings (default: off)
# DEBUG_CFLAGS additional compiler flags for debugging build
# EXTRA_CFLAGS additional compiler flags
@@ -145,6 +146,10 @@ ifneq (,$(findstring all,$(D)))
DEBUG_CFLAGS_INTERNAL += -DDEBUG_ABORT_ON_ERROR=1
endif
+ifneq (,$(findstring asan,$(D)))
+ DEBUG_CFLAGS_INTERNAL += -fsanitize=address
+endif
+
MAKEOPTS = --no-print-directory Q=$(Q)
# build all by default