summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2016-09-03 21:36:53 +0200
committerDavid Sterba <dsterba@suse.com>2016-09-21 11:46:47 +0200
commit9cc6e92972329c939fc5a6945c7acf453b90281c (patch)
tree0caf0ef62e7188f0d6cd0229a7bed2febec152ed /Makefile.in
parenta5bd84871999f0fc4237a36d378678189aa2a185 (diff)
btrfs-progs: build: add UBSAN to debugging features
usage: make D=ubsan Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index fd68b3ee..214b0428 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -18,6 +18,7 @@
# abort - call abort() on first error (dumps core)
# all - shortcut for all of the above
# asan - enable address sanitizer compiler feature
+# ubsan - undefined behaviour sanitizer compiler feature
# W=123 build with warnings (default: off)
# DEBUG_CFLAGS additional compiler flags for debugging build
# EXTRA_CFLAGS additional compiler flags
@@ -150,6 +151,10 @@ ifneq (,$(findstring asan,$(D)))
DEBUG_CFLAGS_INTERNAL += -fsanitize=address
endif
+ifneq (,$(findstring ubsan,$(D)))
+ DEBUG_CFLAGS_INTERNAL += -fsanitize=undefined
+endif
+
MAKEOPTS = --no-print-directory Q=$(Q)
# build all by default