summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2015-10-06 14:53:55 +0200
committerDavid Sterba <dsterba@suse.com>2015-10-21 14:29:26 +0200
commita9a7df9645350888a9c493c8965ad235237d4f80 (patch)
tree99e4fc4fa5e4ea31621fa2d4b37368cac7a5e3c9 /Makefile.in
parentb556a992c3adf892948106503f6572704d877cdb (diff)
btrfs-progs: a bit of makefile documentation
Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.in b/Makefile.in
index 18ebc046..d176998f 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1,3 +1,20 @@
+# btrfs-progs
+#
+# Basic build targets:
+# all all main tools
+# static build static bnaries, requires static version of the libraries
+# test run the full testsuite
+# install install to default location (/usr/local)
+# clean clean built binaries (not the documentation)
+#
+# Tuning by variables (environment or make arguments):
+# V=1 verbose, print command lines (default: quiet)
+# C=1 run checker before compilation (default checker: sparse)
+# W=123 build with warnings (default: off)
+# EXTRA_CFLAGS additional compiler flags
+# EXTRA_LDFLAGS additional linker flags
+#
+
# Export all variables to sub-makes by default
export