summaryrefslogtreecommitdiff
path: root/Makefile.inc.in
diff options
context:
space:
mode:
authorOmar Sandoval <osandov@fb.com>2017-12-18 00:31:25 -0800
committerDavid Sterba <dsterba@suse.com>2018-02-24 01:37:17 +0100
commit23c01b3c1b0803950657f3f29914cd59f3554a84 (patch)
tree970d902219a7c2a2bddc87ed883154c1dee79a65 /Makefile.inc.in
parentd51e8b128f598a31933367ca0fa14b6875b34ca0 (diff)
libbtrfsutil: add Python bindings
The C libbtrfsutil library isn't very useful for scripting, so we also want bindings for Python. Writing unit tests in Python is also much easier than doing so in C. Only Python 3 is supported; if someone really wants Python 2 support, they can write their own bindings. This commit is just the scaffolding. Signed-off-by: Omar Sandoval <osandov@fb.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile.inc.in')
-rw-r--r--Makefile.inc.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.inc.in b/Makefile.inc.in
index b53bef80..159d38ed 100644
--- a/Makefile.inc.in
+++ b/Makefile.inc.in
@@ -14,6 +14,8 @@ DISABLE_BTRFSCONVERT = @DISABLE_BTRFSCONVERT@
BTRFSCONVERT_EXT2 = @BTRFSCONVERT_EXT2@
BTRFSCONVERT_REISERFS = @BTRFSCONVERT_REISERFS@
BTRFSRESTORE_ZSTD = @BTRFSRESTORE_ZSTD@
+PYTHON_BINDINGS = @PYTHON_BINDINGS@
+PYTHON = @PYTHON@
SUBST_CFLAGS = @CFLAGS@
SUBST_LDFLAGS = @LDFLAGS@