summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJosef Bacik <jbacik@fb.com>2014-09-25 16:07:10 -0400
committerDavid Sterba <dsterba@suse.cz>2014-10-01 16:34:29 +0200
commit3ae0209d94776faaa139fcebfafa22fd7840b9f4 (patch)
treeaff0995e2e6bb3614f1a40e4bf1648ede9c341b0 /Makefile
parentafc850dd13e672db63f6ba1faab9d4da6182f5b8 (diff)
Btrfs-progs: make BUG*() be more verbose
Currently these macros just tie to assert(), which gives us line number and such but no backtrace so no actual context. This patch adds support for spitting out a backtrace so we can see how we got to the given assert. Thanks, Signed-off-by: Josef Bacik <jbacik@fb.com> [backtrace_symbols_fd] Signed-off-by: Naohiro Aota <naota@elisp.net> [minor fixups] Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 18eb9445..7cc77839 100644
--- a/Makefile
+++ b/Makefile
@@ -5,7 +5,7 @@ CC = gcc
LN = ln
AR = ar
AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -DBTRFS_FLAT_INCLUDES -fno-strict-aliasing -fPIC
-CFLAGS = -g -O1 -fno-strict-aliasing
+CFLAGS = -g -O1 -fno-strict-aliasing -rdynamic
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o file-item.o inode-item.o inode-map.o \
extent-cache.o extent_io.o volumes.o utils.o repair.o \