summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2007-04-10 09:27:30 -0400
committerDavid Woodhouse <dwmw2@hera.kernel.org>2007-04-10 09:27:30 -0400
commit43f6ab83bf23a9833355b9970ddc600e445f2805 (patch)
treef3c41a277030912d24e4cbad31e44035af22865c /Makefile
parent86c2d787286b888a7f45ee522310f773b8466917 (diff)
btrfsctl
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 50d980a3..219ce80b 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
CC=gcc
CFLAGS = -g -Wall -Werror
headers = radix-tree.h ctree.h disk-io.h kerncompat.h print-tree.h list.h \
- transaction.h
+ transaction.h ioctl.h
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o hash.o file-item.o inode-item.o \
inode-map.o \
@@ -16,7 +16,11 @@ check=sparse $(CHECKFLAGS)
$(check) $<
$(CC) $(CFLAGS) -c $<
-all: bit-radix-test tester debug-tree quick-test dir-test tags mkfs.btrfs
+all: bit-radix-test tester debug-tree quick-test dir-test tags mkfs.btrfs \
+ btrfsctl
+
+btrfsctl: ioctl.h btrfsctl.o
+ gcc $(CFLAGS) -o btrfsctl btrfsctl.o
mkfs.btrfs: $(objects) mkfs.o
gcc $(CFLAGS) -o mkfs.btrfs $(objects) mkfs.o -luuid