summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2010-02-28 15:29:47 -0500
committerChris Mason <chris.mason@oracle.com>2010-02-28 15:35:38 -0500
commit4ff9e2af1721559ec6a8026f5d52a6c9dea805bf (patch)
treec6ada7655bba91393015579d123705637e25e4c2 /Makefile
parentab8fb4c99516c186641bda1dbc0e788f68b4dc77 (diff)
Add btrfs-list for listing subvolumes
Signed-off-by: Chris Mason <chris.mason@oracle.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 02f881e4..f2a9d41a 100644
--- a/Makefile
+++ b/Makefile
@@ -17,7 +17,7 @@ bindir = $(prefix)/bin
LIBS=-luuid
progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck \
- btrfs-map-logical
+ btrfs-map-logical btrfs-list
# make C=1 to enable sparse
ifdef C
@@ -36,6 +36,9 @@ all: version $(progs) manpages
version:
bash version.sh
+btrfs-list: $(objects) btrfs-list.o
+ gcc $(CFLAGS) -o btrfs-list btrfs-list.o $(objects) $(LDFLAGS) $(LIBS)
+
btrfsctl: $(objects) btrfsctl.o
gcc $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)