summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAdam Buchbinder <abuchbinder@google.com>2017-07-10 14:29:08 -0700
committerDavid Sterba <dsterba@suse.com>2017-07-20 17:43:43 +0200
commit50d037b4590ea8eea376d19ad89c152776b4225c (patch)
tree1c1792dd3780fe152307e0592e22d9c89c22bc1e /Makefile
parentb7df24aa5cddc4802b9938f56372b73869775cd9 (diff)
btrfs-progs: tests: Fix missing internal deps in check and misc tests
Doing a straight 'make test' would fail because some misc and fsck tests require particular tools to already be built. Add dependencies at the Makefile and shell-script level. Signed-off-by: Adam Buchbinder <abuchbinder@google.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 9e7886b2..487626f3 100644
--- a/Makefile
+++ b/Makefile
@@ -272,11 +272,12 @@ test-convert: btrfs btrfs-convert
$(Q)bash tests/convert-tests.sh
test-check: test-fsck
-test-fsck: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs
+test-fsck: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs btrfstune
@echo " [TEST] fsck-tests.sh"
$(Q)bash tests/fsck-tests.sh
-test-misc: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs btrfstune fssum
+test-misc: btrfs btrfs-image btrfs-corrupt-block mkfs.btrfs btrfstune fssum \
+ btrfs-zero-log btrfs-find-root btrfs-select-super
@echo " [TEST] misc-tests.sh"
$(Q)bash tests/misc-tests.sh