summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorIan Kumlien <pomac@demius.net>2013-02-05 23:04:22 +0100
committerDavid Sterba <dsterba@suse.cz>2013-02-12 15:22:57 +0100
commit93f06520b8966cda3ecd603cd45465f9557a2989 (patch)
tree9edf364929ac8ff7f4080ab5285311849291d3ef /Makefile
parent6e0ade17670e319e486df4c6d5fb438d22dc98fa (diff)
Btrfs-progs: -U_FORTIFY_SOURCE before -D
My builds are cluttered with: <command-line>:0:0: warning: "_FORTIFY_SOURCE" redefined [enabled by default] Which makes it hard to tell if something breaks or not. Signed-off-by: Ian Kumlien <pomac@demius.net>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index d9dd07a9..9e912a28 100644
--- a/Makefile
+++ b/Makefile
@@ -1,5 +1,5 @@
CC = gcc
-AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
+AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
CFLAGS = -g -O1
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o file-item.o inode-item.o \