summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2008-07-24 12:13:30 -0400
committerDavid Woodhouse <dwmw2@hera.kernel.org>2008-07-24 12:13:30 -0400
commit9864c90760e7c0f287cc616d5f71a674efbbc5ea (patch)
treed26b1f1c7a9777618070a99f41c824db79465f0c /Makefile
parentcbfe93f68fb47513386bca429e35e6265091bd86 (diff)
Print the version string in a few programs
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 287ce5ab..e50d7b7c 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,10 @@ endif
$(CC) $(DEPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c $<
-all: $(progs)
+all: version $(progs)
+
+version:
+ bash version.sh
btrfsctl: $(objects) btrfsctl.o
gcc $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)