summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2010-03-15 11:24:20 -0400
committerChris Mason <chris.mason@oracle.com>2010-03-15 11:24:20 -0400
commitfb3a539c9224b9923acccc684bc1f2719d651004 (patch)
treeaf001ee9e26fbf9df2318daa857b160ffc1e1b43 /Makefile
parentb72e4c4e1923b908b7242c7d6646391eb4043a93 (diff)
Add ioctl-test.c which just prints all the ioctl numbers.
This is used to compare the output on 64 bit and 32 bit machines and make sure all of our ioctls are compat defined.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9735fc6e..525676e1 100644
--- a/Makefile
+++ b/Makefile
@@ -77,6 +77,9 @@ quick-test: $(objects) quick-test.o
convert: $(objects) convert.o
gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
+ioctl-test: $(objects) ioctl-test.o
+ gcc $(CFLAGS) -o ioctl-test $(objects) ioctl-test.o $(LDFLAGS) $(LIBS)
+
manpages:
cd man; make