summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAdam Buchbinder <abuchbinder@google.com>2014-05-21 10:20:27 -0700
committerDavid Sterba <dsterba@suse.cz>2014-08-22 14:39:35 +0200
commit2100836188672d64adf0def8975dceea710ce51c (patch)
tree0dba4504e81933c0348cb347eaea913afa2a6a83 /Makefile
parent700c3ca9b1312c19ed5c657da3137a6b6f6fa63c (diff)
btrfs-progs: Add some simple end-to-end tests for btrfs-convert
These use the system's mke2fs, and don't require loop devices or root privileges. They don't pick up anything with the default flags right now, but they do pick up some sanitizer issues when the tools are compiled with any of -fsanitize={address,memory,thread}. Signed-off-by: Adam Buchbinder <abuchbinder@google.com> Signed-off-by: David Sterba <dsterba@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fd30047e..8e14d483 100644
--- a/Makefile
+++ b/Makefile
@@ -21,7 +21,7 @@ libbtrfs_objects = send-stream.o send-utils.o rbtree.o btrfs-list.o crc32c.o \
libbtrfs_headers = send-stream.h send-utils.h send.h rbtree.h btrfs-list.h \
crc32c.h list.h kerncompat.h radix-tree.h extent-cache.h \
extent_io.h ioctl.h ctree.h btrfsck.h
-TESTS = fsck-tests.sh
+TESTS = fsck-tests.sh convert-tests.sh
INSTALL = install
prefix ?= /usr/local