summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2007-10-15 16:25:41 -0400
committerDavid Woodhouse <dwmw2@hera.kernel.org>2007-10-15 16:25:41 -0400
commit28de03cb0aa69a75c51ee9dcf68942319eefed0b (patch)
tree388a55e5827b19822c4a6199f490328409316edd /Makefile
parent38f79f9077fce76eabc5566319f33b8e800fb96d (diff)
Create a slightly more generic extent-caching structure
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index aca10613..3355e807 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@ CC=gcc
CFLAGS = -g -Wall -fno-strict-aliasing -Werror
objects = ctree.o disk-io.o radix-tree.o extent-tree.o print-tree.o \
root-tree.o dir-item.o hash.o file-item.o inode-item.o \
- inode-map.o crc32c.o rbtree.o pending-extent.o \
+ inode-map.o crc32c.o rbtree.o extent-cache.o \
#
CHECKFLAGS=-D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ -Wbitwise \
-Wuninitialized -Wshadow -Wundef
@@ -12,8 +12,7 @@ INSTALL= install
prefix ?= /usr/local
bindir = $(prefix)/bin
-#progs = btrfsctl btrfsck mkfs.btrfs debug-tree
-progs = btrfsctl mkfs.btrfs debug-tree
+progs = btrfsctl btrfsck mkfs.btrfs debug-tree
# make C=1 to enable sparse
ifdef C