summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-02-20 14:58:57 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-08 13:00:48 +0100
commit2b92a224c7713465150d3e3f57246dc054108284 (patch)
treed6e2c1040d01d2a909c4fc8841befc2f728a98d4 /Makefile
parent6fc48715ac79936b94e0b8b4a03ae6f9ce827cb6 (diff)
btrfs-progs: tests: fix library-test rules and deps
The symbol __error was undefined and the rule did not use the dependencies from the rule definiton, like the rest. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2b8e929f..67fbc483 100644
--- a/Makefile
+++ b/Makefile
@@ -446,15 +446,15 @@ test-ioctl: ioctl-test ioctl-test-32 ioctl-test-64
$(Q)./ioctl-test-32 > ioctl-test-32.log
$(Q)./ioctl-test-64 > ioctl-test-64.log
-library-test: library-test.o $(libs_shared)
+library-test: library-test.o messages.o $(libs_shared)
@echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) -o $@ library-test.o $(LDFLAGS) -Wl,-rpath=$(TOPDIR) -lbtrfs
+ $(Q)$(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -Wl,-rpath=$(TOPDIR) -lbtrfs
@echo " [TEST] $@"
$(Q)./$@
-library-test.static: library-test.static.o $(libs_static)
+library-test.static: library-test.static.o messages.static.o $(libs_static)
@echo " [LD] $@"
- $(Q)$(CC) $(STATIC_CFLAGS) -o $@ library-test.static.o $(STATIC_LDFLAGS) $(libs_static) $(STATIC_LIBS)
+ $(Q)$(CC) $(STATIC_CFLAGS) -o $@ $^ $(STATIC_LDFLAGS) $(libs_static) $(STATIC_LIBS)
@echo " [TEST] $@"
$(Q)./$@