summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorAnand Jain <anand.jain@oracle.com>2013-01-28 13:22:30 +0800
committerDavid Sterba <dsterba@suse.cz>2013-01-30 00:40:35 +0100
commit46e3b8087b86ef555b13be6807c34c555171fc4a (patch)
tree0a12035e30f7661f11aee0f96ec61be6319b6e7e /Makefile
parent4a64455231d41b8c23c980cb20959242d2fbff78 (diff)
Btrfs-progs: move open_file_or_dir() to utils.c
The definition of the function open_file_or_dir() is moved from common.c to utils.c in order to be able to share some common code between scrub and the device stats in the following step. That common code uses open_file_or_dir(). Since open_file_or_dir() makes use of the function dirfd(3), the required XOPEN version was raised from 6 to 7. Signed-off-by: Anand Jain <anand.jain@oracle.com> Original-Signed-off-by: Stefan Behrens <sbehrens@giantdisaster.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 4dd405d3..1b1c045e 100644
--- a/Makefile
+++ b/Makefile
@@ -57,9 +57,9 @@ all: version $(progs) manpages
version:
$(Q)bash version.sh
-btrfs: $(objects) btrfs.o help.o common.o $(cmds_objects)
+btrfs: $(objects) btrfs.o help.o $(cmds_objects)
@echo " [LD] $@"
- $(Q)$(CC) $(CFLAGS) -o btrfs btrfs.o help.o common.o $(cmds_objects) \
+ $(Q)$(CC) $(CFLAGS) -o btrfs btrfs.o help.o $(cmds_objects) \
$(objects) $(LDFLAGS) $(LIBS) -lpthread
calc-size: $(objects) calc-size.o