summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2017-02-01 13:23:04 +0100
committerDavid Sterba <dsterba@suse.com>2017-03-08 13:00:46 +0100
commit5eff096b78548791d30c7b261608287c69e30030 (patch)
tree1bced86f7d3a12698f3e4faebfd5b3666d0405aa /Makefile
parent0c94504d0649d0a31a0716e8ace19de153aadc29 (diff)
btrfs-progs: build: use MAKEOPTS where missing
$(MAKE) should also use MAKEOPTS. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 94b7c4ce..e3bab951 100644
--- a/Makefile
+++ b/Makefile
@@ -299,7 +299,7 @@ test-clean:
test-inst: all
@tmpdest=`mktemp --tmpdir -d btrfs-inst.XXXXXX` && \
echo "Test installation to $$tmpdest" && \
- $(MAKE) DESTDIR=$$tmpdest install && \
+ $(MAKE) $(MAKEOPTS) DESTDIR=$$tmpdest install && \
$(RM) -rf -- $$tmpdest
test: test-fsck test-mkfs test-convert test-misc test-fuzz test-cli
@@ -461,16 +461,16 @@ library-test.static: library-test.static.o $(libs_static)
test-build: test-build-pre test-build-real
test-build-pre:
- $(MAKE) clean-all
+ $(MAKE) $(MAKEOPTS) clean-all
./autogen.sh
./configure
test-build-real:
- $(MAKE) library-test
- -$(MAKE) library-test.static
- $(MAKE) -j 8 all
- -$(MAKE) -j 8 static
- $(MAKE) -j 8 $(progs_extra)
+ $(MAKE) $(MAKEOPTS) library-test
+ -$(MAKE) $(MAKEOPTS) library-test.static
+ $(MAKE) $(MAKEOPTS) -j 8 all
+ -$(MAKE) $(MAKEOPTS) -j 8 static
+ $(MAKE) $(MAKEOPTS) -j 8 $(progs_extra)
manpages:
$(Q)$(MAKE) $(MAKEOPTS) -C Documentation