summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2007-02-26 10:40:21 -0500
committerDavid Woodhouse <dwmw2@hera.kernel.org>2007-02-26 10:40:21 -0500
commit8f3b86bae341d96e0aef7b7052bdf30e25df7d29 (patch)
treeb54d4c7141ca746caf1a64b7d0510199c519487c /Makefile
parentf463391fd2bfe9041d79adaf61491c153cf41624 (diff)
Add fsx-style randomized tree tester
Add debug-tree command to print the tree Add extent-tree.c to the repo Comment ctree.h
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index fe73ab9d..855e8f49 100644
--- a/Makefile
+++ b/Makefile
@@ -6,11 +6,17 @@ objects = ctree.o disk-io.o radix-tree.o mkfs.o extent-tree.o print-tree.o
#.c.o:
# $(CC) $(CFLAGS) -c $<
-ctree : $(objects)
- gcc $(CFLAGS) -o ctree $(objects)
+all: tester debug-tree
+
+debug-tree: $(objects) debug-tree.o
+ gcc $(CFLAGS) -o debug-tree $(objects) debug-tree.o
+
+tester: $(objects) random-test.o
+ gcc $(CFLAGS) -o tester $(objects) random-test.o
$(objects) : $(headers)
clean :
rm ctree *.o
+