summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2007-02-28 16:35:06 -0500
committerDavid Woodhouse <dwmw2@hera.kernel.org>2007-02-28 16:35:06 -0500
commit92ce8be1205795980188281de2399790e969cca5 (patch)
tree607076272485bca8c3dce03763cabee4b6a0fe29 /Makefile
parent9b4f51240cfb9da74a17c8509e8d6ef8d1496ac4 (diff)
return code checking
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 078061c3..58d4260a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,10 +1,13 @@
+CC=gcc
CFLAGS = -g -Wall
headers = radix-tree.h ctree.h disk-io.h kerncompat.h print-tree.h
objects = ctree.o disk-io.o radix-tree.o mkfs.o extent-tree.o print-tree.o
# if you don't have sparse installed, use ls instead
-check=sparse
+CHECKFLAGS=-D__linux__ -Dlinux -D__STDC__ -Dunix -D__unix__ -Wbitwise \
+ -Wcontext -Wcast-truncate -Wuninitialized -Wshadow -Wundef
+check=sparse $(CHECKFLAGS)
#check=ls
.c.o: