summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2007-02-28 09:40:58 -0500
committerDavid Woodhouse <dwmw2@hera.kernel.org>2007-02-28 09:40:58 -0500
commit9b4f51240cfb9da74a17c8509e8d6ef8d1496ac4 (patch)
tree15be31217dd5d4ea1f9890d41c04cbc8a14a462d /Makefile
parent0317678f007ff755d439f944cd7ece090f08b429 (diff)
Add sparse checking to Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index ea9b6665..078061c3 100644
--- a/Makefile
+++ b/Makefile
@@ -3,8 +3,13 @@ CFLAGS = -g -Wall
headers = radix-tree.h ctree.h disk-io.h kerncompat.h print-tree.h
objects = ctree.o disk-io.o radix-tree.o mkfs.o extent-tree.o print-tree.o
-#.c.o:
-# $(CC) $(CFLAGS) -c $<
+# if you don't have sparse installed, use ls instead
+check=sparse
+#check=ls
+
+.c.o:
+ $(check) $<
+ $(CC) $(CFLAGS) -c $<
all: tester debug-tree