summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorChris Mason <chris.mason@oracle.com>2008-04-28 16:44:22 -0400
committerDavid Woodhouse <dwmw2@hera.kernel.org>2008-04-28 16:44:22 -0400
commitb327761ead72a42f253bb45b6b03fefdb15edec4 (patch)
tree2d536c30e3a7a2e01f3226b75bb2f431da10638d /Makefile
parent083faf794fd87a7897545a2a16a15599f62beffb (diff)
Add btrfs-vol command to balance, add and (eventually) remove devices
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 58dfa5fa..7100852e 100644
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ prefix ?= /usr/local
bindir = $(prefix)/bin
LIBS=-luuid
-progs = btrfsctl btrfsck mkfs.btrfs debug-tree btrfs-show
+progs = btrfsctl btrfsck mkfs.btrfs debug-tree btrfs-show btrfs-vol
# make C=1 to enable sparse
ifdef C
@@ -34,6 +34,9 @@ all: $(progs)
btrfsctl: $(objects) btrfsctl.o
gcc $(CFLAGS) -o btrfsctl btrfsctl.o $(objects) $(LDFLAGS) $(LIBS)
+btrfs-vol: $(objects) btrfs-vol.o
+ gcc $(CFLAGS) -o btrfs-vol btrfs-vol.o $(objects) $(LDFLAGS) $(LIBS)
+
btrfs-show: $(objects) btrfs-show.o
gcc $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)