summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorQu Wenruo <wqu@suse.com>2018-02-01 13:37:31 +0800
committerDavid Sterba <dsterba@suse.com>2018-02-02 16:01:59 +0100
commitb8d706e58e69a4782cae111049636e439db86f44 (patch)
tree33beea7aac23b99d91aa201235c72b901004268e /Makefile
parent5dade4b9514cbb765c9c2905172bb371b7479a77 (diff)
btrfs-progs: check: Move lowmem check code to its own check/lowmem.[ch]
Since lowmem mode code is highly internally connected, it's pretty hard to move them piece by piece. In theory it's possible to move part of the functions and temporarily export them, but it will just cause extra temporarily modifications. So this patch moves the whole lowmem check part into its own check/lowmem.[ch]. Signed-off-by: Qu Wenruo <wqu@suse.com> Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index dfc116c7..d30f1d29 100644
--- a/Makefile
+++ b/Makefile
@@ -113,7 +113,7 @@ cmds_objects = cmds-subvolume.o cmds-filesystem.o cmds-device.o cmds-scrub.o \
cmds-restore.o cmds-rescue.o chunk-recover.o super-recover.o \
cmds-property.o cmds-fi-usage.o cmds-inspect-dump-tree.o \
cmds-inspect-dump-super.o cmds-inspect-tree-stats.o cmds-fi-du.o \
- mkfs/common.o check/common.o
+ mkfs/common.o check/common.o check/lowmem.o
libbtrfs_objects = send-stream.o send-utils.o kernel-lib/rbtree.o btrfs-list.o \
kernel-lib/crc32c.o messages.o \
uuid-tree.o utils-lib.o rbtree-utils.o