summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorDavid Sterba <dsterba@suse.com>2018-02-22 12:45:14 +0100
committerDavid Sterba <dsterba@suse.com>2018-03-06 11:28:37 +0100
commite0d173c6c44d52287f2e20ec104cb3840e558343 (patch)
treee62f10a19d4381703b6420884d699b04bbeab264 /Makefile
parent624e0233e09a034a0b8a6da445f725706ef2d9f8 (diff)
libbtrfsutil: add stub for reallocarray
This function is new in glibc 2.26 and breaks build in CI and possibly other environments. Signed-off-by: David Sterba <dsterba@suse.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 24af13a4..6065522a 100644
--- a/Makefile
+++ b/Makefile
@@ -136,7 +136,8 @@ libbtrfsutil_minor := $(shell sed -rn 's/^\#define BTRFS_UTIL_VERSION_MINOR ([0-
libbtrfsutil_patch := $(shell sed -rn 's/^\#define BTRFS_UTIL_VERSION_PATCH ([0-9])+$$/\1/p' libbtrfsutil/btrfsutil.h)
libbtrfsutil_version := $(libbtrfsutil_major).$(libbtrfsutil_minor).$(libbtrfsutil_patch)
libbtrfsutil_objects = libbtrfsutil/errors.o libbtrfsutil/filesystem.o \
- libbtrfsutil/subvolume.o libbtrfsutil/qgroup.o
+ libbtrfsutil/subvolume.o libbtrfsutil/qgroup.o \
+ libbtrfsutil/stubs.o
convert_objects = convert/main.o convert/common.o convert/source-fs.o \
convert/source-ext2.o convert/source-reiserfs.o
mkfs_objects = mkfs/main.o mkfs/common.o mkfs/rootdir.o